LisaList2

Advanced search  

News:

2019.06.07 fixed NChat for the "Curve" theme, will eventually move it to its own page and add it to the default theme as well. Other plugins are next. see post in the Meta board for details

Poll

Anyone want 64 bit LisaEm on PowerMac G5?

I don't care about LisaEm on PowerPC for macosx
- 3 (50%)
I only need 32-bit PowerPC for macosx
- 1 (16.7%)
I'd like to see a 64-bit PowerPC (G5) LisaEm
- 2 (33.3%)

Total Members Voted: 6

Voting closed: November 07, 2019, 12:30:30 pm


Pages: [1]   Go Down

Author Topic: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?  (Read 871 times)

rayarachelian

  • Administrator
  • Sr. Member
  • *****
  • Karma: +7/-0
  • Online Online
  • Posts: 158
  • "But what's puzzling you is the nature of my game"
    • LisaEm
LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« on: October 08, 2019, 01:30:30 pm »

I'll post up binaries for the ALPHA test release of LisaEm 1.2.7 in the next 2-3 days, slightly earlier than I'd like, but due to Catalina, I need to publish at least x86_64 at Catalina kills off 32 bit executables. For this, I'm using an older ~2009 10.9.5 macbook, as I don't readily have anything older that currently works and supports 64 bit x86 binaries, so that would be the cutoff for x86_64 at least for the immediate future - that won't stop you from compiling it yourself.

I'm trying to get wxWidgets built for 64 bit mode PowerPC on macos x 10.5.8, but I'm running into various errors. (Not sure if 10.4 will support 64 bit binaries).
So, I'm wondering does anyone still care about PowerPC support on OS X? If so is 64 bit desirable or is 32 bit sufficient?

[ If you're curious, github has 1.2.7 that I've pushed out ~ Friday night, which works on Linux - at least Ubuntu 18.04.x, but does not have the proper build scripts for os x which I've been hacking on over the weekend. I'll push the changes out when I publish the DMGs. ]
Logged
Fate whispers to the warrior, 'You can not withstand the storm.'  The warrior whispers back, 'I am the storm.'

stepleton

  • Jr. Member
  • **
  • Karma: +9/-0
  • Offline Offline
  • Posts: 10
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #1 on: October 08, 2019, 03:22:19 pm »

Not much to say here... just congrats on getting close to this release, and thanks for all your hard work on LisaEm! It would be a different hobby without it. --Tom
Logged

rayarachelian

  • Administrator
  • Sr. Member
  • *****
  • Karma: +7/-0
  • Online Online
  • Posts: 158
  • "But what's puzzling you is the nature of my game"
    • LisaEm
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #2 on: October 08, 2019, 03:51:17 pm »

Thanks Tom.  :)
Logged
Fate whispers to the warrior, 'You can not withstand the storm.'  The warrior whispers back, 'I am the storm.'

jamesdenton

  • Full Member
  • ***
  • Karma: +20/-0
  • Offline Offline
  • Posts: 28
  • ArcaneByte
    • ArcaneByte
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #3 on: October 08, 2019, 08:45:07 pm »

I don't have a G5 these days, so I'm afraid I'm no help to you there. But like Tom, I'm just glad to see you're still at it and appreciate the hard work.
Logged

Lisa2

  • Administrator
  • Full Member
  • *****
  • Karma: +12/-0
  • Offline Offline
  • Posts: 28
  • See why 1983 was more like Y2K...
    • Lisa2.com
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #4 on: October 09, 2019, 03:19:29 am »

Ray,
I do think having a 32 bit PPC port is important, i do not think a 64 bit PPC version is of any priority.  That said, i do have a G5, and could do some testing if you need me too.
Thanks,
Rick
Logged

rayarachelian

  • Administrator
  • Sr. Member
  • *****
  • Karma: +7/-0
  • Online Online
  • Posts: 158
  • "But what's puzzling you is the nature of my game"
    • LisaEm
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #5 on: October 09, 2019, 12:27:20 pm »

So some history, I started LisaEm on a Dec Alpha AXP (Multia) running OpenBSD, I've had it on various v8 and v9 SPARC machines, and MacPower PC as well as most recently ARM, so I do aim for trying to keep it as portable as possible. G5 64 bit is interesting if I can get wxWidgets to compile properly. :) But it looks like it's not a priority from the current answers of this poll.

I do have 1.2.7-ALPHA working just fine on 32 bit PPC right now, but on x86_64 with clang it crashes with a segfault on startup now. meh... I'm gonna try to use brew.sh to install gcc and see if that will fix it, or be able to trace down the error. lldb is gcc like but it didn't tell me exactly where it segfaulted when I did list like gcc does. Obviously x86_64 os x is the highest priority for right now.
Logged
Fate whispers to the warrior, 'You can not withstand the storm.'  The warrior whispers back, 'I am the storm.'

D.Finni

  • Full Member
  • ***
  • Karma: +9/-0
  • Offline Offline
  • Posts: 33
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #6 on: October 10, 2019, 01:37:34 pm »

My main computer for running LisaEm is an Intel Mac OS X 10.5.8.

But I also have an iMac G5 running 10.5.8.
Logged

rayarachelian

  • Administrator
  • Sr. Member
  • *****
  • Karma: +7/-0
  • Online Online
  • Posts: 158
  • "But what's puzzling you is the nature of my game"
    • LisaEm
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #7 on: October 13, 2019, 05:11:03 pm »

Finally got it to build properly on x86_64 on 10.11, needs loads of testing, but had to do with with differences between libstdc++ and libc++.
Will need to give it a bunch testing before I cut a DMG. Timing will depend on how many bugs I find.

I've pushed the current code to github, incase you're impatient and willing to build it yourself :-) https://github.com/rayarachelian/lisaem-1.2.x
Edit: found it's crashing in sound play, will debug after tonight.
« Last Edit: October 14, 2019, 10:32:26 am by rayarachelian »
Logged
Fate whispers to the warrior, 'You can not withstand the storm.'  The warrior whispers back, 'I am the storm.'

jamesdenton

  • Full Member
  • ***
  • Karma: +20/-0
  • Offline Offline
  • Posts: 28
  • ArcaneByte
    • ArcaneByte
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #8 on: October 14, 2019, 11:15:13 am »

Hi Ray -

I got it to build on 10.15. Happy to share my build process, but I've probably gone wrong somewhere. The app is built an will open, but I end up with a Level 7 Interrupt upon booting.

James
Logged

rayarachelian

  • Administrator
  • Sr. Member
  • *****
  • Karma: +7/-0
  • Online Online
  • Posts: 158
  • "But what's puzzling you is the nature of my game"
    • LisaEm
Re: LisaEm 1.2.7-Alpha is pending, is G5 64-bit support wanted?
« Reply #9 on: October 14, 2019, 05:53:54 pm »

Hi Ray -

I got it to build on 10.15. Happy to share my build process, but I've probably gone wrong somewhere. The app is built an will open, but I end up with a Level 7 Interrupt upon booting.

James

Ya, so I just pushed again last night on github, it does build now. I've also added a scripts dir to ease the pain of building wxWidgets, so you should be able to just run that guy and then add the resulting 64 bit directory from /usr/local/wx3.1.2*/bin to the front of the path before building LisaEm, but there's some error with clang/macos X where that causes a segfault at the delete at line 7772, causing LisaEm to die. I need to fix that guy and likely some more stuff.

Pls reply here: https://lisalist2.com/index.php/topic,52.0.html , as this is getting tangentially off topic to this thread.

I think what may be happening is that the my_lisa_sound is already playing something and then a new call generates another sound, which causes it to die. Either that or somehow my_lisa_sound got deleted without being NULL'ed out,

Yeah, if you've got some stuff other than what I've got so far, pls share.
« Last Edit: October 14, 2019, 05:55:40 pm by rayarachelian »
Logged
Fate whispers to the warrior, 'You can not withstand the storm.'  The warrior whispers back, 'I am the storm.'
Pages: [1]   Go Up